Get in touch
Back
Degraded

New Review updates delayed

Started 26 Jun at 05:12pm GMT+0, resolved 27 Jun at 08:56am GMT+0.

app.reviewshake.com
Resolved

Review updates have now returned to normal, all services are fully operational.

Posted 27 Jun at 08:56am GMT+0.
Created

As a result of a high volume of requests submitted to our service, we’re currently experiencing slower than usual updates of reviews on profiles in Reviewshake accounts. All existing reviews are still visible and nothing else in the platform is affected, however new reviews will be slow to update. We expect this to be resolved within the next 24 hours

Posted 26 Jun at 05:12pm GMT+0.