Get in touch
Back
Downtime

Services down

Started 20 Sep at 10:00am GMT+0, resolved 20 Sep at 11:06am GMT+0.

app.reviewshake.com
Resolved

The issue has been fixed and all services are back online and running as normal

Posted 20 Sep at 11:06am GMT+0.
Created

Our services are currently down and no reviews are being collected. Our team is actively investigating the incident and will update you as soon as possible.

Posted 20 Sep at 10:00am GMT+0.