Back
Downtime

Review collection processing is down
Started 31 Oct at 09:36am GMT-1, resolved 31 Oct at 03:31pm GMT-1.
Background processing
Resolved
All services are now online, and job processing has returned to normal. We'll continue to monitor performance. Thank you for your patience and understanding.
Posted 31 Oct at 03:31pm GMT-1.

Updated
Services are back online and jobs processing should resume. We are going through some backlog of requests but should be back to normal shortly
Posted 31 Oct at 03:01pm GMT-1.

Created
We currently experiencing problems processing review collection. Our team is actively investigating the incident and will update you as soon as possible.
Posted 31 Oct at 09:36am GMT-1.