Back
Downtime

Review collection is down
Started 7 Nov at 11:22am GMT-1, resolved 8 Nov at 07:52am GMT-1.
app.reviewshake.com
Resolved
All systems are back to normal, and review collection is functioning as expected
Posted 8 Nov at 07:52am GMT-1.

Updated
The issue impacting review collection has been resolved. Review collection is currently slower than usual but services should be back to normal soon. We will confirm when this is the case. Thanks for your patience
Posted 7 Nov at 04:11pm GMT-1.

Created
We currently experiencing problems collecting reviews. Our team is actively investigating the incident and will update you as soon as possible.
Posted 7 Nov at 11:22am GMT-1.