Back
Degraded

Slow review collection
Started 5 Dec at 12:48pm GMT-1, resolved 5 Dec at 08:02pm GMT-1.
app.reviewshake.com
Resolved
All services are operating normally and review collection has resumed. We will continue to monitor the system. We appreciate your patience during the interruption.
Posted 5 Dec at 08:02pm GMT-1.

Created
We are currently experiencing delays collecting reviews. Our team is actively investigating and we will update you as soon as possible.
Posted 5 Dec at 12:48pm GMT-1.