Back
Degraded

Delay in review collection
Started 25 Feb at 07:22am GMT-1, resolved 25 Feb at 04:33pm GMT-1.
app.reviewshake.com
Resolved
Review collection has returned to normal, and we are actively monitoring service performance.
Posted 25 Feb at 04:33pm GMT-1.

Created
We are currently experiencing delays collecting reviews. Our team is actively investigating and we will update you as soon as possible.
Posted 25 Feb at 07:22am GMT-1.