Get in touch
Back
Resolved

Services are currently degraded

Started 26 May at 09:15am GMT+0.

app.reviewshake.com Background processing
Created

Jobs have been processing slower than usual. Fixes have been deployed, and we are working through the backlog, while monitoring.

Posted 26 May at 09:15am GMT+0.