Back
Degraded

Delayed review collection
Started 30 May at 06:30am GMT+0, resolved 30 May at 02:12pm GMT+0.
app.reviewshake.com
Resolved
Review collection is now back to normal. Thanks for your patience and understanding
Posted 30 May at 02:12pm GMT+0.

Created
We are currently experiencing delays collecting reviews. Our team is actively investigating and we will update you as soon as possible.
Posted 30 May at 06:30am GMT+0.